Jump to content

Welcome to Omni-bot Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

8.4 omni-bot help on heavy weapons

- - - - -

  • Please log in to reply
12 replies to this topic

#1
Raner

Raner

    Junior Member

  • Members
  • PipPip
  • 26 posts

HI... Running Silent 8.2...

How to remove or limit the use of mortar on 8.4 bots...

Found this...

[HeavyWeapons]
# Limits heavy weapons on the server. Bots won't use the specified weapon
# until player count is reached in the team.
# MinPlayersForMortar: Limits the bot usage of the mortar. (-1=disabled)
MinPlayersForMortar            = -1
If  (-1=disabled)
Can someone explain in a bit more detail what settings to use in the bot.cfg to eliminate or restrict  the mortar...
I have 4 bots per team running...
Thanks for any help you can provide...


#2
palota

palota

    Senior Member

  • Administrators
  • 561 posts

Bots don't use mortar if total number of players is less than value MinPlayersForMortar.

You can set MinPlayersForMortar = 99 if you want to disable mortar.


  • Mateos likes this

#3
Raner

Raner

    Junior Member

  • Members
  • PipPip
  • 26 posts

Thanks Palota...



#4
hellreturn

hellreturn

    Senior Member

  • Members
  • 155 posts

Can we have something similar for Panzer and Flamer? 


referral-0104343001382132136.gif lback-banner_mygamingtalk.jpg

logo.png


#5
JohnDory

JohnDory

    Senior Member

  • Members
  • 200 posts

why just set up either default.cfg or a map-name.cfg with the settings you want in it.

set team_maxPanzers 0
set team_maxFlamers 0

Cheers.

 

Mike.


#6
hellreturn

hellreturn

    Senior Member

  • Members
  • 155 posts

 

why just set up either default.cfg or a map-name.cfg with the settings you want in it.

set team_maxPanzers 0
set team_maxFlamers 0

 

That would disable panzers within human players as well. I don't want that. I only want omni bots not to use panzer since we have 1 panzer per team.  Worse part is .. if someone is having panzer, then next map during map start, omni bots would take up panzer. 

 

Is there anyway so that omni bots don't spawn as soldier? That would solve my issue.


referral-0104343001382132136.gif lback-banner_mygamingtalk.jpg

logo.png


#7
JohnDory

JohnDory

    Senior Member

  • Members
  • 200 posts

you can set in et_autoexec.gm file that you do not want any bot soldiers but I'm not sure about telling them not to use what weapons as soldiers. sorry you need some one more in to scripting, or perhaps lua ?


Cheers.

 

Mike.


#8
hellreturn

hellreturn

    Senior Member

  • Members
  • 155 posts

You mean remove it from here?

Util.PlayerClassTable =
{
	CLASS.SOLDIER,
	CLASS.MEDIC,
	CLASS.ENGINEER,
	CLASS.FIELDOPS,
	CLASS.COVERTOPS,
};

referral-0104343001382132136.gif lback-banner_mygamingtalk.jpg

logo.png


#9
palota

palota

    Senior Member

  • Administrators
  • 561 posts

It's not recommended to modify et_autoexec.gm.  It's better to create a new file et_autoexec_user.gm  for all your settings. The file should be in folder omni-bot/et/scripts.

 

If you want to disable panzer and flamethrower, add these commands to et_autoexec_user.gm:

WeaponTable.SetWeaponAvailability(CLASS.SOLDIER, WEAPON.PANZERFAUST, false);
WeaponTable.SetWeaponAvailability(CLASS.SOLDIER, WEAPON.FLAMETHROWER, false);
WeaponTable.SetWeaponTeamAvailability(TEAM.AXIS, CLASS.SOLDIER, WEAPON.MP40, true);
WeaponTable.SetWeaponTeamAvailability(TEAM.ALLIES, CLASS.SOLDIER, WEAPON.THOMPSON, true);

If you want to disable soldiers and you have the latest Omni-bot version from Assembla, add these commands to et_autoexec_user.gm:

Server.MinClassCount[TEAM.AXIS][CLASS.SOLDIER] = 0;
Server.MinClassCount[TEAM.ALLIES][CLASS.SOLDIER] = 0;

If you want to disable soldiers and you have Omni-bot version 0.84, you must modify MinClassCount values in et_autoexec.gm.


  • JohnDory, d00d, hellreturn and 1 other like this

#10
hellreturn

hellreturn

    Senior Member

  • Members
  • 155 posts

It's not recommended to modify et_autoexec.gm.  It's better to create a new file et_autoexec_user.gm  for all your settings. The file should be in folder omni-bot/et/scripts.

 

If you want to disable panzer and flamethrower, add these commands to et_autoexec_user.gm:

WeaponTable.SetWeaponAvailability(CLASS.SOLDIER, WEAPON.PANZERFAUST, false);
WeaponTable.SetWeaponAvailability(CLASS.SOLDIER, WEAPON.FLAMETHROWER, false);
WeaponTable.SetWeaponTeamAvailability(TEAM.AXIS, CLASS.SOLDIER, WEAPON.MP40, true);
WeaponTable.SetWeaponTeamAvailability(TEAM.ALLIES, CLASS.SOLDIER, WEAPON.THOMPSON, true);

If you want to disable soldiers and you have the latest Omni-bot version from Assembla, add these commands to et_autoexec_user.gm:

Server.MinClassCount[TEAM.AXIS][CLASS.SOLDIER] = 0;
Server.MinClassCount[TEAM.ALLIES][CLASS.SOLDIER] = 0;

If you want to disable soldiers and you have Omni-bot version 0.84, you must modify MinClassCount values in et_autoexec.gm.

 

Does this still hold true? I believe i had tried something and it resulted in server crash. Using 0.85 and 0.86 omni's on different servers. Slowly moving towards 0.86 one by one.


referral-0104343001382132136.gif lback-banner_mygamingtalk.jpg

logo.png


#11
palota

palota

    Senior Member

  • Administrators
  • 561 posts

Which config values resulted in server crash ? Do you have any logs, stack trace or console output ?



#12
VargaTom

VargaTom

    Junior Member

  • Members
  • PipPipPip
  • 98 posts
  • LocationNorth of Hungary

How do I configure in .gm file : when Axis team have blasted the main door then axis engineers spawn GPG40 only



#13
palota

palota

    Senior Member

  • Administrators
  • 561 posts

If you want engineers to use GPG40 only, disable other weapons:

WeaponTable.SetWeaponTeamAvailability(TEAM.AXIS, CLASS.ENGINEER, WEAPON.MP40, false);

  • VargaTom likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users