Jump to content

Welcome to Omni-bot Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

View Other Content



Search Articles



Recent Comments


* * * * *

Omni-Bot ET 0.83 Released!


Omni-Bot 0.83 for Enemy Territory has been released.
We are pleased to announce the latest version of Omni-bot for ET has been released. Palota has been very busy this past year fixing bugs, adding features, and adding support for newer mods. The waypoint team has also been busy adding support for new maps and improving on existing waypoints.

Release Highlights
  • ETBlight and Bastard mods are supported
  • Fixed memory leak caused by GameMonkey threads
  • Fixed crash in AddBot if bot is kicked in ClientUserinfoChanged
  • Added cvar omnibot_logsize (maximal file size in KB), -1 will disable logs, 0 will overwrite file every match
A complete change log can be found in the download section.

[NOTE: An updated version of the Linux package has been added to the download section to address a GLIBC issue with some distributions. Please use the 0.831 version if the bot library is failing to load for you.]
  • d00d, IRATA [*], Mateos and 1 other like this


10 Comments

Photo
StoerFaktoR
Nov 24 2013 02:10 PM

We get a error if we try to run this version  :/

 

http://omni-bot.invi...-nicht-geladen/

are previous versions running correctly on the same server?

I can't get it to start either. The test server was running 0.82 before. I didn't modify anything in the omni-bot.cfg except to change maxbots  to 16 and difficulty to 3.

 

Is there a new pk3 and qagame file or am I correct in assuming to use the ones from the 0.82 version? I just replaced the omni-bot directory with the 0.83, and left the omnibot directory the same as 0.82. Let me know if I missed them somewhere...

ok all good, we have it running.

Photo
StoerFaktoR
Nov 25 2013 03:02 PM

@crapshoot: yes 

@StoerFaktoR: can you replace the omnibot_et.so with this one? I've updated the package in the download section, but it's just that file that needs replaced.

Photo
StoerFaktoR
Nov 26 2013 06:11 AM

Yeah , know it works .

Many thanks :)

Well done guys!

Are you completely sure memory leak was fixed?

Are you completely sure memory leak was fixed?

 

We're completely sure that A memory leak was fixed. If you suspect additional problems, please post about it in the forum.